Audacity - VoIP.ms Wiki

Check out our YouTube channel to watch our simple tutorials that will help you set up most of our features.

Audacity

From VoIP.ms Wiki

Jump to: navigation, search

Audacity is a free, third-party open-source audio editing tool, useful in creating recordings for upload to the system.

These recordings, once uploaded, may be used as announcements in IVRs, calling queues, failover options or be used as a destination to which to route a DID number.

IMPORTANT: The sound file must be a non-compressed Windows .WAV sound file (extension .wav) with the format: PCM, 8kHz, 16 bits and Mono.
The recordings cannot be used for your Voicemail Custom Greeting, please refer to our Voicemail page for how to set this properly.

Contents

Download and installation

Audacity

Audacity is available for Windows, Linux PC and Macintosh computers; it may be downloaded freely at http://audacity.sourceforge.net/download/windows

Most Linux distributions include Audacity, which can be installed automatically from the package manager (usually "apt-get install audacity" or "yum install audacity").

Recording

  • Select File → New
  • Select an input source (such as a microphone)
  • Adjust the recording levels using the microphone volume control at the top of the screen
  • Press "record" and record your message
  • Press "stop".

Your recorded audio is now ready to be edited or saved.

Editing

Audacity has a wide range of capabilities, many of them overkill for simple IVR recording tasks or intended as special effects for editing music. A full manual is online at http://manual.audacityteam.org/o/ — here is a short introduction to a few commonly-used tasks:

Trim a recording
  • Use the mouse to select the portion of the audio track you wish to keep (go to the start, press and hold the button, drag the mouse to the end, release)
  • Click the "trim audio" icon (which looks like a waveform with the beginning and end flatlined)
  • All except the selected portion will be discarded, useful for removing blank/silent/unused segments before or after your actual recording
Cut, copy and paste
  • The standard scissors, clipboard and duplicate page icons are available:
  • Use the mouse to select the portion of the audio track you wish to copy
  • Click the "copy" icon
  • The audio may now be pasted into a different position in the same or another track (use File → Duplicate to create an identical second track for editing)
Concatenate two or more recordings
  • Use File → Open to open the initial WAV file
  • Select Project → Import Audio to import a second WAV file
  • Click the Time Shift Tool (horizontal double-headed arrow button)
  • Use the double-headed arrow to drag the start of the second WAV file to the right so that it starts after the first recording ends
  • Press Control-A (or Edit → Select all) to select all tracks at once
  • Select File → Export As WAV to save the combined WAV files as a single WAV (from [1])

There are libraries with various stock phrases and standard announcements on http://downloads.asterisk.org/pub/telephony/sounds — these messages (two huge gzip archives, asterisk-core-sounds-en-wav-current.tar.gz and asterisk-extra-sounds-en-wav-current.tar.gz) are available in the correct format for the system but by design one often needs to concatenate or copy-and-paste multiple messages, such as:

  • "The number you have reached..."
  • "...eight..."
  • "...six..."
  • "...seven..."
  • "...five..."
  • "...three..."
  • "...oh..."
  • "...nine..."
  • "...has been disconnected."
  • "Please hang up..."

to identify individual extensions or individual error conditions. For these concatenations, audio editing software is invaluable.

Export and upload

To save your recording in non-compressed Windows .WAV sound file (extension .wav) with the format: PCM, 8kHz, 16 bits and Mono:

  • From the pull-down menu at the upper-left corner of the individual audio track, select "Mono"
  • From the "Project Rate (Hz)" pull-down box at the lower-left corner of the screen, select "8000"
  • From the "File → Export" menu item, select "WAV (Microsoft) signed 16-bit PCM" in the pull-down box above the "Save" button
  • Give your new .wav recording a descriptive name and click "Save"

To upload a recording, login to the customer portal and go to DID numbers → Recordings.

Recording2.JPG

  • Name: you can set the name you want to identify this recording
  • File: here you need to select the recording you want to upload on your account.
  • Upload: click on this to start uploading procedure.

When you upload a new recording, the system can take up to 60 seconds to propagate this recording to all VoIP servers. It will not be playable until this process is complete. See Recordings for more information on using recordings once they have been uploaded to the system.

Personal tools
Namespaces
Variants
Actions
VoIP.ms Blog
Guides (Français)
Guías (Español)